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EDA322Digital Design Lab 

  LAB 1 

Designed by: Anurag Negi, Angelos Arelakis, Ioannis Sourdis 

 

 
In this lab you will familiarize yourself with two sets of tools – the first, called QuestaSim(or 
ModelSim – no difference between these two tools for the course requirements) lets you 
simulate your VHDL hardware descriptions, while the second, called Xilinx ISE,allows you to 
synthesize your designs and target a variety of hardware platforms. This lab assumes that you 
are at least aware of what FPGAs are and where they can be used. 
 
We will see how to use the following tools in this lab: 

1. QuestaSim/ModelSim: This tool allows you to compile and simulate descriptions of 
digital logic in VHDL. A student edition is available free for Windows. 

2. XilinxISE: This tool allows you to synthesize your VHDL designs and map the resulting 
logic onto a variety of target devices. We will target the Nexys3 board equipped with a 
Spartan 6 (XC6LX16-CS324) device. Note the number in parenthesis, as it would be 
needed to correctly setup your development environment when using Xilinx ISE. Again, 
a free student license is available for this software.  
 

This lab will require you to completethree tasks: 
1. Learn to recognize and understand the use of several commonly occurring digital logic 

components. 
2. Simulate a sample VHDL design inQuestaSim/ModelSimand check for correctness of 

operation using a “do” file. 
3. Synthesize the sample VHDL design targeting a Xilinx Spartan-6 FPGA platform and 

read off some relevant design parameters from reports. 
 
Please download eda322_lab1.zip from PingPong and extract its contents in a local folder which 
you can access from within QuestaSim/Modelsim and XilinxISE. The .zip archive contains two 
files: eda322_lab1.vhd and eda322_lab1.do.  
 

Using QuestaSim/ModelSim for simulating VHDL designs – Task 1 

 
Start QuestaSim/ModelSim. You should see a window similar to the one shown below.  
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We will now create a new project, by selecting File->New->Project. Name the project EDA322. 
All code you write in this course canbe part of this project. Choose a suitable Project Location, 
so that your code is maintained in a secure place.  
 

 
 
Once you click OK, the software will ask you to add items to the project. You can select “Add 
existing file” and add the VHDL file (with the extension “.vhd” or “.vhdl”) to the project. You 
can add files to the project at a later point in time as well. It is not required for the files to be 
located in the project folder. 
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The window should now be similar to the image below: 
 

 
 
Double clicking on the file name will open the file for editing in an editing panel. You can now 
take a look at how the description of a simple hardware component looks like in VHDL.  
 
You can compile it by selecting Compile->Compile All from the menu. If there are errors or 
warnings, you can see them by double clicking on the error message (appeared in red) in the 
Transcript window. A new window appears where the errors/warnings are listed, like in the 
figure below. Using this information you can fix them and recompile. 
 

 
 
When compilation is successful, you should be able to see a green tick mark in the status field 
beside the file name.  
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You can simulate the design by selecting Simulate -> Start Simulation. It will present a dialogue 
box asking you to choose the design entity that you want to simulate. In the “work” library, 
choose the name of the entity (or the top level entity if you have several entity descriptions 
comprising your design).In this lab, the entity name “eda322_lab1”is the top level entity in your 
default “work” library.  
 

 
You should now see a window that looks similar to the one shown below: 
 

 
 
Signal names in the simulated entity appear in the Objects panel. You can right click on signal 
names you want to view graphically in the panel and select “Add Wave”. A new waveform 
panel will appear with the signal(s) shown. In alternative, you can select the signals (in Objects) 
you would like to add in the waveform and then drag and drop them in the signal area of it.  
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Also notice the Transcript panel at the bottom of the QuestaSim/Modelsim window (see Figure 
in the next page), which also displays a command line. 
 

 
 
You can now enter commands to test your module.  Type “do eda322_lab1.do” to run the do file 
you have downloaded. Make sure that the “do” file is placed in the working directory for the 
project. 
 
You can see that values in the waveform window are updated when the run command is 
executed. The figure below shows various signal transitions when a VHDL module is 
simulated. You can zoom in/out using the respective “magnifying glass” tools. You can also 
change the radix which the signals appear in by right clicking on a signal (or a set of them) and 
selecting radix. A signal can be added a number of times using different radixes (can be done 
through the graphic interface or inside the “do” file), which can be practical. 
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The “do” file contains a sequence of commands that can also be entered at the console. A quick 
guide and a command reference have been provided for your guidance on PingPong. It is 
strongly recommended to do testing (adding signals to the waveform view, assign signal 
values, run simulation time)using “do” files.This way makes it very easy to repeat the 
simulation when debugging and during the lab demonstrations. 
 
Take some time at this point to familiarize yourselves with the syntax of the .do file and with the 
features available in the simulator -- like adding/removing signals from the waveform window, 
zooming in and out, cursor control, changing the way values are represented in the window 
(radix). Getting familiar with these controls will help you test and debug code more effectively – 
a skill which will be valuable throughout the lab assignment. 
 

Try to answer the following questions and check your answers with an assistant: 
 
1. What functionality is modeled in the code? 
 
2. How many flip-flops have been used in the code? 
 
3. What happens when the “aresetn” port is set to 0?  
 

Synthesizing your design – Task 2 

 

You can use Xilinx ISE to synthesize your design. Synthesis converts your VHDL description 
into a netlist of components that can be mapped onto a target device like an FPGA. For this lab 
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we will target a Xilinx Spartan 6 FPGA (XC6SLX16) in a CSG324 package. The design tool also 
does the mapping onto the FPGA and applies user constraints (like mapping top level design 
ports onto pins on the FPGA board). 
 
Run XilinxISE and click on File->New Project …  
A dialogue box similar to the one shown below should open up. Give your project a name and 
provide a safe location and a working directory. Choose “Top-level source type” as HDL since 
you will be writing VHDL code to describe your designs. Notethat when you create a project 
using XilinxISE, a new folder will be created at the location you have chosen, in contrast to 
QuestaSimthat doesn´t do this. 
 

 
 
Clicking next will bring you to a dialogue box similar to the one shown below: 
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Choose all settings as shown in the image above. Click “Next >” and then “Finish”. Note that 
these setting include choosing the correct FPGA device (as noted in the introductory section of 
this document) and the preferred hardware description language, which for this course is 
VHDL. 
 
You should now have a Xilinx window than looks similar to the one shown below. 
 

 
 
Right-clicking on the project name in the Design tab would provide a menu (shown below) that 
allows you to add sources to your Xilinx project.  
 



EDA322 Lab 1 D&IT, Chalmers 2018 

9 
 

 
 

 

You already have VHDL source provided to you. You can click on “Add Source…” which 

would allow you to browse and select an existing VHDL file.  

You can also choose to use Xilinx ISE as an editor for creating new VHDL codes. In that case 

choose “New Source…” and provide a filename, selecting “VHDL Module” as source type. This 

would bring you to a dialogue box similar to the one shown below. 

 

 
 

You can describe the VHDL entity using this dialogue box and the tool will automatically add 

that to the file, which you can then fill in to describe how the entity behaves. As you can see, it 

allows you to specify port names and directions. Check the “Bus” checkbox if a port is wider 

than a single bit. 

 

Once you have added VHDL files and/or completed coding, you should have the Xilinx ISE 

window looking similar to the one shown below: 
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You may have to identify a top-level module if you have a hierarchy of VHDL modules before 

you begin synthesis. The “Source” menu allows you do to so.  

 

Right-clicking on “Create Timing Constraints” under “User Constraints” and selecting “Design 

Goals and Strategies” brings up a dialogue box as shown below. It allows you to choose among 

several design goals that allow designers to target different area vs. power vs. performance 

tradeoffs. The image below shows a design where a “Balanced” approach has been selected.  

 

 
 

Create a clock timing constraint by double clicking on “Create timing constraints” and selecting 

“Clock Domains” constraint type. Apply it to the signal called “clk” and constrain it to a 5ns 

period.  The result would look similar to the image shown below: 
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Save the constraint. Xilinx ISE creates a UCF (user constraints file) that contains text 

specifications for each constraint imposed by the user. The particular constraint instructs the 

tool to do everything possible to implement the circuit in such a way that the clock period does 

not exceed 5ns. This enables you to “push” the tool to achieve a minimum performance – 

something you will need to do in (the optional) Lab 7. 

 

Now you are all set to begin synthesis of your design by double clicking on “Synthesize – XST” 

in the Design tab.  Though this sample design will synthesize without errors or warnings, in 

future labs this is an important stage where you will be able to fix many problems that might 

exist in more complex designs.  

 

Double click on implement design to invoke “Translate”/Map/PAR algorithms in the tool. 

These steps convert a synthesized netlist into a design that is suitable for implementation on the 

targeted device. Several optimizations may happen here to optimize based on resources 

available on the FPGA and constraints provided by the designer.  

 

Take a look at the Design Summary section in the Synthesis report. Also take a look at Post 

Place and Route Timing Report. Try to understand the meaning and implications of various 

terms and numbers you see in these reports. 

 

Try to answer the following questions and check your answers with an assistant: 

 

1. How many flip-flops were used to implement the design? 

 

2. How many LUTs (look-up tables) were used to implement the design? 

 

3. What is the maximum net delay post place and route? 

 

Perform a power analysis by running “Generatetext power report” under “Place and Route” -

>“Generate post place and route static timing” in the design tab. What is the reported total 
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design power in mW? Note that this number may be inaccurate for reasons beyond the scope of 

the present lab. The intention here is to introduce you to the types of analyses that can be 

performed using Xilinx ISE. 

 

 

Hints and Tips: 
 

Installing ModelSim and Xilinx on your personal device  

The student version of ModelSim [1]and Xilinx-ISE WebPACKDesign Software[2]are sufficient for 

the labs in this course. You can download and use these tools onyour own device fromthe links 

provided at the end of this document. 

 

Forcing values in the .do file 

Depending on the version of the ModelSim you use, you are allowed to utilize differentformats 

forassigning a value to a signal. But, it is strongly recommended that you use the generally 

accepted explicit format where # symbol should be used to define the radix of a value. For 

instance:  

- force mySignal 2#101  

where binary value "101" is assigned to mySignal, or  

- force mySignal 10#240 

where decimal value "240" is assigned to mysignal. 

 

Problem with generating the text power report: 
Sometimes, after running “Generate Text Power Report”, the report is still inaccessible. If this 

happened, right click on “Generate Text Power Report”, go to “Process Properties” and make 

sure that “Produce Verbose Report” is checked. Rerun all.  
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