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Varfér LabVIEW?

e Obligatoriska laborationer.
o LabVIEW-uppgifter kommer pa tentan.

e Anvinds av mangder av foretag.
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Arbetsmiljo Programmeringsgrunder Strukturer S Grafer Sammanfattning

CHALMERS
Nar LabVIEW?

e 30/1, 10:15: Introduktion

e 30/1, 13:15: Introduktion (forts.)

e 31/1, 13:15: Introduktionsdvningar (grupp A)
e 6/2, 10:15: Repetition och exempel

e 7/2, 13:15: Introduktionsévningar (grupp B)

e 8/2, 8:15: Lésningar till évningar

e 16/2, 8:15: LAB 3 (grupp A) (obligatoriskt)
e 23/2, 8:15: LAB 3 (grupp B) (obligatoriskt)

e 1/3, 10:15: Filhantering, Instrumentkommunikation, VISA, DAQ
Assistant, Linear Fit.

e 1/3, 13:15: LAB 4 (grupp A) (obligatoriskt)
e 2/3, 8:15: LAB 4 (grupp B) (obligatoriskt)
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Oversikt

1. Arbetsmiljo

2. Programmeringsgrunder
3. Strukturer

4. Arrays

5. Grafer

6. Sammanfattning
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Arbetsmiljé ’rogramm gsgrunder Strukturer S Sammanfattning

CHALMERS
LabVIEW

e Laboratory Virtual Instrument Engineering Workbench
o Grafisk programeringsmiljo
o Ett LabVIEW-program kallas Virtual Instrument (VI)
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Programmerir

runder Strukturer Grafer

CHALMERS
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Arbetsmiljo Strukturer

Grafer

CHALMERS
Frontpanel
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e Anvandargranssnitt.

e Uppbyggt av kontroller (inputs) och indikatorer (outputs).
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Arbetsmiljé
CHALMERS

Blockdiagram

L

S & @ N P 9 bam s 1intApplication Fom | B Tav b s @‘ :

Temperatur (*C)
i Temperatur {°F)

o |

e Innehaller den grafiska koden
o Bestar av:

e Terminaler
o Funktioner
e Konstanter
e Kopplingar
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Arbetsmiljé
CHALMERS

Blockdiagram

L

S & @ N P 9 bam s 1intApplication Fom | B Tav b s @‘ :

Temperatur (*C)
i Temperatur {°F)

o |

e Innehaller den grafiska koden
o Bestar av:
e Terminaler
o Funktioner
Konstanter
Kopplingar
Strukturer
Sub VI'n
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Arbetsmiljo
CHALMERS

Verktyg

View » Tools Palette
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Arbetsmiljo
CHALMERS

Verktyg

View » Tools Palette

Automatic Tool Selector
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Arbetsmiljo
CHALMERS

Verktyg

View » Tools Palette

Automatic Tool Selector

Operating Tool
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Arbetsmiljo
CHALMERS

Verktyg

View » Tools Palette

Automatic Tool Selector

Operating Tool

Positioning Tool
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Arbetsmiljo
CHALMERS

Verktyg

View » Tools Palette

Automatic Tool Selector

Operating Tool

Positioning Tool

Labeling Tool
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Arbetsmiljo
CHALMERS

Verktyg

View » Tools Palette

Automatic Tool Selector
Operating Tool
Positioning Tool

Labeling Tool

Wiring Tool
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Arbetsmiljo
CHALMERS

Verktyg

View » Tools Palette

Automatic Tool Selector
Operating Tool
Positioning Tool
Labeling Tool

Wiring Tool

Coloring Tool
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Arbetsmiljo
CHALMERS

Status
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Arbetsmiljo
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Arbetsmiljo
CHALMERS
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Arbetsmiljo
CHALMERS

Status
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Arbetsmiljé
CHALMERS

Status
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Arbetsmiljé
CHALMERS

Status
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Pause
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Highlight Execution
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Arbetsmiljé
CHALMERS

Status
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Highlight Execution
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Arbetsmiljé
CHALMERS

Status
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Abort Execution
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Highlight Execution

Step

Align, Distribute, Reorder
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Programmeringsgrunder
CHALMERS

Oversikt

2. Programmeringsgrunder
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Programmeringsgrunder
CHALMERS

Exempel

Exempel 1: Celsius till Fahrenheit

Skriv ett program som omvandlar grader Celsius (°C) till grader Fahrenheit
(°F). Anvind féljande formel:

TDF:§-T0c+32
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Programmeringsgrunder
CHALMERS

Kopplingar

e Skicka data mellan objekt i blockdiagrammet genom kopplingar.
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Arbetsmiljé Programmeringsgrunder Strukturer S Sammanfattning

CHALMERS
Kopplingar

e Skicka data mellan objekt i blockdiagrammet genom kopplingar.

e Farg, stil och tjocklek beror pa datatyp.

Typ Skalar | 1D Array | 2D Array

Heltal

Flyttal

Boolskt

Strang
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Programmeringsgrunder
CHALMERS

Exekveringsordning

El

& O N P 20 wam s | 1t Application Fort ~ | B Wov Gbe ad @‘
[3

Temperatur (°C)
. Tcmpcramr (°F)
J nall
[eh s

e En nod exekveras nar den har alla nédvandiga inputs.

e Nar en nod exekveras producerar den utdata och skickar till nasta nod i
dataflodet.
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Programmeringsgrunder
CHALMERS

Exekveringsordning

S® @I § ¥ wa o | 1otApplication Font ~ | B Fiov GBv Lad @‘

b Area (cm*2)
b
I .ne

Omkrets (cm)

Cirkelradie (cm)

e Det kan vara omdjligt att siga vilken av oberoende noder som exekveras
forst.

e Om exekveringsordningen &r viktig maste vi anvianda en Sequence
Structure.
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Programmeringsgrunder
HALMERS

Hjalp

e Context Help

Two Button Dialog

message e Visar grundlaggande information om
T button name (*OK") ‘AN T button? objekt.
F butten name ("Cancel”}

Displays a dialog box that contains a message and two
buttons.

Terminal Data Type
T button? (boolean (TRUE or FALSE))

Detailed help
wal? [z
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Programmeringsgrunder
CHALMERS

Hjalp

e Context Help
e Visar grundlaggande information om

Two Button Dialog

message
T button name {"OK") T button? objekt.
F butten name ("Cancel”} . T
e Visa/délj i Help » Show Context
Displays a dialog box that contains a message and two
buttons. Help (ﬁg@H)
Terminal Data Type
T button? {boolean (TRUE or FALSE
Detailed help
#[E[? (7
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Programmeringsgrunder

CHALMERS
Hjalp

e Context Help

Two Button Dialog
e Visar grundlaggande information om
T button? objekt.

message
T button name (“0K") M
F butten name ("Cancel”} . T
e Visa/délj i Help » Show Context

Displays a dialog box that contains a message and two
buttons. Help (ﬁg@H)

Terminal Data Type
T button? (boolean (TRUE or FALSE))

Detailed help
wal? [z

Two Button Dialog Fu;ch’on e LabVIEW H E|p

Busme O vt s e Detaljerad information om funktioner
) = - i LabVIEW.

Contents | ndox || Searen

[ 446 tothe block diagram (3] Find on the patette

8 messase s the txt o iy i he g bo. e g
o capands when you 36 more et Ti uncton

he T Buton Des VL. Wi s U, you o convert >
e button dlog box t 3 one o i button iag box by
Wiring an mpty sing t 3 button et nput t hide that
Euttan

T button name is the nome disleyed on one of the dialog
Box buttons. The defaut s OK.

me s the name displayed on one of the dialog
Eox buttons The defaut 15 Canéel

T button? returns a value of TRUE I you clckthe dialog box
button named n name. I you dck he liogbox
button named F button name or cick the cose wi

Bulton, T button? returns 3 value of FALSE.
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Programmeringsgrunder
ALMERS

Hjalp

e Context Help

Two Button Dialog
e Visar grundlaggande information om
T button? objekt.

message
T button name (“0K") M
F butten name ("Cancel”} . T
e Visa/délj i Help » Show Context

Displays a dialog box that contains a message and two
buttons. Help (ﬁg@H)

Terminal Data Type
T button? (boolean (TRUE or FALSE))

Detailed help
wal? [z

Two Button Dialog Fu;ch‘on e LabVIEW H E|p

Contents | ndox || Searen

Py e Detaljerad information om funktioner

[2] g xamate vt Displays a dislog box that cont

(2 Glossary

\ljl LabvIEw Ne\p

 message and two buttons.

i LabVIEW.

el o Oppna i Help » LabVIEW Help eller
e o @ genom att klicka p3 Detailed

B e Help-lanken.

hree bution dislog bos to 3 one o two button diiog box by
Wiring an mpty sing t 3 button et nput t hide that
Euttan

T button name is the nome disleyed on one of the dialog
Box buttons. The defaut s OK.

F button name is the name displayed on ane of the cslog

Eox buttons The defaut 15 Canéel

[EEE] T button? returns a value of TRUE i you cick the dalog box
button named n name. 1 you dck the laog box
bulton named F button name or cck the cose window
Bulton, T button? returns 3 value of FALSE.
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Programmeringsgrunder
CHALMERS

Felsokning

“Testing shows the presence, not the absence of bugs.” Edsger Dijkstra
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Programmeringsgrunder Strukturer

CHALMERS
Felsokning

“Testing shows the presence, not the absence of bugs.” Edsger Dijkstra

e Inom all programmering finns buggar som kan
o forhindra att programmet kors.
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Programmeringsgrunder Strukturer

CHALMERS
Felsokning

“Testing shows the presence, not the absence of bugs.” Edsger Dijkstra

e Inom all programmering finns buggar som kan

o forhindra att programmet kors.
e generera felaktiga resultat.
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Programmeringsgrunder
CHALMERS
Felsokning

B8O N G 2 am s [T -] G oo B3 2B

e Om LabVIEW-programmet inte
kan koras indikeras detta genom

]| B area tcmr2) brut Run-pil IEI
,i, en bruten Run-pi

Omiets (em)

Cirkelrade (cm)
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Programmeringsgrunder

Felsokning

S5O0 0 s rotemieenron - S G e B3 9 e Om LabVIEW-programmet inte
kan koras indikeras detta genom

en bruten Run-pil [,

Cirkelrade (cm)

e Vad gora? Tryck pd symbolen for
att 6ppna Error List Window.

Items with errors

4 errors and warnings Show Warnings

& Block Diagram Errors
Multiply: Contains unwired or bad tarminal

Square: Contains unwired or bad terminal
You have connected an input of Square to an input of Multiply. Change one to
Polymorphic terminal cannot accept this data type.

Details

One or more required inputs to this function are not wired or are wired incorrectly.
Show the Context Help window to see what the connections to this function should
be.

Close Show Errer Help
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Programmeringsgrunder
CHALMERS

Felsokning

e Om programmet kérs men producerar felaktiga resultat:
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Programmeringsgrunder
CHALMERS

Felsokning

e Om programmet kérs men producerar felaktiga resultat:

o Anvind Highlight Execution (@] [&],
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Programmeringsgrunder Strukturer

CHALMERS
Felsokning

e Om programmet kérs men producerar felaktiga resultat:

o Anvind Highlight Execution (@] [&],
e Anvind Step Into, Step Over och Step Out i

LET271: LabVIEW | J. Pedersen 18 /42



Programmeringsgrunder Strukturer

CHALMERS
Felsokning

e Om programmet kérs men producerar felaktiga resultat:

o Anvind Highlight Execution (@] [&],
e Anvind Step Into, Step Over och Step Out i
e Anvind Probe Tool .
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Arbetsmiljé Programmeringsgrunder Strukturer S Sammanfattning

CHALMERS
Felsokning

e Om programmet kérs men producerar felaktiga resultat:

o Anvind Highlight Execution (@] [&],
e Anvind Step Into, Step Over och Step Out i
e Anvind Probe Tool .

Exempel 2: Felsdkning
Kor ett program med namnda metoder. J
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Arbetsmiljé Programmeringsgrunder Strukturer s Grafer Sammanfattning

CHALMERS

Kortkommandon

Mac  Windows Beskrivning

$8E Ctrl E Visa frontpanelen

{r3¢H  Ctrl H  Visa/délj hjilp

¥Z Ctrl Z Angra

£ Ctrl R Run

HT Ctrl T Frontpanelen och blockdiagrammet sida vid sida
3B Ctrl B Ta bort trasiga kopplingar
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Strukturer
CHALMERS

Oversikt

3. Strukturer
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Strukturer
CHALMERS

Strukturer

o Innehaller sektioner med grafisk kod.
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Strukturer
CHALMERS

Strukturer

o Innehaller sektioner med grafisk kod.
e Kontrollerar hur och nar koden exekveras.
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Strukturer

CHALMERS
Strukturer

o Innehaller sektioner med grafisk kod.

e Kontrollerar hur och nar koden exekveras.
While Loop

For Loop

Case Structure

Sequence Structure

Formula Node
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Strukturer
CHALMERS

While Loop

e Exekverar koden tills ett villkor ar
uppfyllt.

3

Condition met?
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Strukturer
CHALMERS

While Loop

o Exekverar koden tills ett villkor ar
uppfyllt.
o Koden exekveras minst en gang.

3

Condition met?
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Strukturer
CHALMERS

While Loop

e Exekverar koden tills ett villkor ar
uppfyllt.
o Koden exekveras minst en gang.

o lterationsterminal: Antal
iterationer (raknar fran 0).

3

Condition met?
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Strukturer
CHALMERS

While Loop

e Exekverar koden tills ett villkor ar
uppfyllt.

o Koden exekveras minst en gang.

o lterationsterminal: Antal
iterationer (raknar fran 0).

Villkorsterminal:

e Stanna om sant
o Fortsitt om sant

3
[ ]

Condition met?
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Strukturer

CHALMERS
For Loop

=
=
=
Z

o Exekverar koden ett forutbestamt
antal ganger.
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Strukturer

CHALMERS

For Loop

N . .
L o Exekverar koden ett forutbestamt
antal ganger.
e Raknare: Indikerar antalet
iterationer.
S
Gl 7
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mmerin d Strukturer s Grafer

CHALMERS

For Loop

=
=
=
Z

o Exekverar koden ett forutbestamt
antal ganger.

e Raknare: Indikerar antalet
iterationer.

o lterationsterminal: Antal
| P iterationer (réknar fran 0 till N-1).
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Strukturer
CHALMERS

Loop Timing

o Nar en iteration i loopen avslutas
startar nasta iteration omedelbart.

milliseconds to wait

stop
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Strukturer
CHALMERS

Loop Timing

o Nar en iteration i loopen avslutas
startar nasta iteration omedelbart.

e Anviand Wait-funktionen for att ge
milliseconds to wait . .
processorn tid slutféra andra

| stap uppgifter.
[XET]
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Strukturer
CHALMERS

Loop Timing

o Nar en iteration i loopen avslutas
startar nasta iteration omedelbart.

e Anviand Wait-funktionen for att ge
milliseconds to wait . .
processorn tid slutféra andra

| stap uppgifter.
[XET]

m ........

Exempel 3: Loopar

Skriv ett program som indikerar iterationerna i en for-loop fér N = 20. Anvand
en wait-funktion. Gor detsamma med en while-loop som kan avslutas efter 20
iterationer eller nar anvandaren avslutar programmet.
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Strukturer
CHALMERS

Shift Registers

; B ) | o Skicka data fran féregdende
— iteration med Shift Register.
=1 43> —

D

Led

lThe Loop repeats every 1000 ms
]
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Strukturer
CHALMERS

LET271:

Shift Registers

=
|> Numeric
oo

= £
Led

‘The Loop repeats every 1000 ms
]

7

LabVIEW | J. Pedersen

o Skicka data fran féregdende
iteration med Shift Register.

e Skapa genom att hogerklicka pa
hoger eller vansterkanten och vélj
Add Shift Register.

25 /42



Arbetsmiljé runder Strukturer

Grafer Sammanfattning

CHALMERS
Shift Registers

‘ B Jﬂ o Skicka data fran foregdende
* Numesie J iteration med Shift Register.
= & » 9 e Skapa genom att hogerklicka pa

hoger eller vansterkanten och vélj

Add Shift Register.

‘The Loop repeats every 1000 ms

]

Exempel 4: Shift Register

Skriv ett program som slumpar fram ett heltal mellan 0 och 10 varje sekund

tills programmet avslutas av anvandaren. Det nuvarande och féregdende
slumptalet ska visas pa skdarmen.
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Strukturer

CHALMERS
Case
e Har tva eller fler subdiagram.
o Exekverar endast ett diagram.
140, Default Vt M1 't
Expression Expression
. s g

7]
3
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Strukturer

CHALMERS
Stacked Sequences

o Ett eller flera subdiagram som exekveras sekventiellt.

e Garanterar att ett subdiagram kérs fore ett annat.

DDDDDI‘ID[ug]vLIDE\DD DDDDDI‘II[DB]'LIDDDD Ooo0o00Qqn 2[“3]'LIDDDD
.. | L, | —E .. s

5 5 &
0000000000000 00 0000000000000 00 0000000000000 00
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rammeri srunder Strukturer s Grafer Sammanfattni

Arbetsmiljo

CHALMERS
Stacked Sequences

o Ett eller flera subdiagram som exekveras sekventiellt.
e Garanterar att ett subdiagram kérs fore ett annat.

o Sekvensen startar nar all data kopplad till sekvensen finns tillganglig.

DDDDDI‘ID[ug]vLIDE\DD DDDDDI‘II[DB]'LIDDDD Ooo0o00Qqn 2[“3]'LIDDDD
.. | L, | —E .. s

0000000000000 00 00000000000 00o00 0000000000000 00
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srunder Strukturer s Grafer Sammanfattni

rammeri

Arbetsmiljo

CHALMERS

Stacked Sequences

Ett eller flera subdiagram som exekveras sekventiellt.
e Garanterar att ett subdiagram kérs fore ett annat.
o Sekvensen startar nar all data kopplad till sekvensen finns tillganglig.

e Data fran varje subdiagram lamnar néar alla subdiagram har korts.

DDDDDI‘ID[ug]vLIDE\DD DDDDDI‘II[DB]'LIDDDD Ooo0o00Qqn 2[“3]'LIDDDD
.. | L, | —E .. s

0000000000000 00 00000000000 00o00 0000000000000 00
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rammeri srunder Strukturer

Arbetsmiljo

CHALMERS
Stacked Sequences

Skicka data mellan subdiagram:
e Anvind Sequence Locals

o Hogerklicka pa kanten och valj Add Sequence Local

0000000000000000 Doooo0o00000000000 Opoooooooooooooong
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Strukturer
CHALMERS

Formula Node

inputvariablelintﬂw , e Evaluerar matematiska formler i
if (x==0) tput variable . .
y=1; blockdiagrammet. Syntaxen liknar
—Toel else y=-1; [ :

deni C.
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Strukturer
CHALMERS

Formula Node

inputvariablelintﬂw , e Evaluerar matematiska formler i
: if (x»=0) output variable . .

iz y=1 blockdiagrammet. Syntaxen liknar
—Toel else y=-1; [

deni C.

e GIom inte att avsluta ett uttryck
med semikolon (;).
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Strukturer
CHALMERS

Formula Node

inputvariableliﬂtﬂw , e Evaluerar matematiska formler i
. if (e==0) output variable . .
iz y=1; blockdiagrammet. Syntaxen liknar
—Toel else y=-1; [ .

deni C.

e GIom inte att avsluta ett uttryck
med semikolon (;).

o |igg till inputs och outputs
genom att hogerklicka pa kanten
och vélja Add Input/Output.
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Arrays
CHALMERS

Oversikt

4. Arrays
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Arrays
CHALMERS

Arrays

e Kombinera data av samma typ i en datastruktur.

e Forsta indexet i en array ar 0.

Array 3

-

70 IHello

this

‘m‘m‘

string
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Arbetsmiljé runder Strukturer Arrays Grafer Sammanfattning

CHALMERS
Skapa Arrays

o Liagg till ett Array Shell.

Array o Ligg ett dataobjekt eller element

4
7 sresierieciesieres, )
=30 '3 ] i skalet.
L 4 assess N
' : . . !
- ’ .
H . 1 f
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Arrays

CHALMERS
Auto-Indexed Tunnels

|- .

Brray o Autoindexerade tunnlar ger ett

&= woe1]| nytt element fér varje
loopiteration.
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Arrays

CHALMERS
Auto-Indexed Tunnels

|- .

Brray o Autoindexerade tunnlar ger ett

&= woe1]| nytt element fér varje
loopiteration.

Exempel 5: Autoindexerade tunnlar

Skriv ett program som sparar 5 slumptal 0 eller 1 med lika stor sannolikhet i en
array.
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Arrays

Skapa 2D Arrays

CHALMERS

e Anviand nastlade for-loopar.

e Yttre loopen ger radindex och inre loopen ger kolumnindex.

Row

EHE 2D Array
Column & 0 =
LR s 0,62742¢ 10,93283¢ |0,69886: 0

3

0 rray 9\[. 0,30379: 10,92450¢ |0,38478: 0
= . — 0,86954: |0,246037 |0,63657¢ 0
0,00267¢ |0,25250: 10,12012: 0
0 P 0,90886¢ |0,13301¢ |0,71774¢ 0
m o 1] 0 0 1]
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Arrays

CHALMERS
Exempel pa Arrayfunktioner

Index Array e Returnera vardet av ett element
n-dimension array +8 med specificerat index.
index 0 | elernent or subarray

indes no1

Returns the element or subarray of n-dimension
array atindex.
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Arrays

CHALMERS
Exempel pa Arrayfunktioner

Index Array e Returnera vardet av ett element
n-dimension array +8 med specificerat index.
index 0 | elernent or subarray

indes no1

Returns the element or subarray of n-dimension
array atindex.

Build Array

o Lagg till varden till en array.

appended array

element

Concatenates multiple arrays or appends
elements to an n-dimensional array.
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Arrays
CHALMERS

Exempel pa Arrayfunktioner

Index Array e Returnera virdet av ett element
med specificerat index.

n-dimension array
index 0
index n-

elernent or subarray

Returns the element or subarray of n-dimension
array atindex.

Build Array o Lagg till varden till en array.

array
element

element

appended array

element

Concatenates multiple arrays or appends
elements to an n-dimensional array.

Transpose 2D Array ° Transponera €n array.

transposed array

2D array

Rearranges the elements of 2D array such
that 2D array/[i,j] becomes transposed
array|[j,i].

35/42
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Grafer
CHALMERS

Oversikt

5. Grafer
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Grafer
CHALMERS

Plotta Grafer

Olika typer av grafer i LabVIEW:
o Waveform Chart

e Waveform Graph
o XY Graph
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Arbetsmiljé Programmeringsgrunder Strukturer Grafer Sammanfattning

CHALMERS

Waveform Chart

o Visar data kontinuerligt 6ver tid.

Waveform Chart Plot 0 m I Waveform Charts:

“Wire data directly to chart:
Data | Resulting Chart

ns—

Scalar | Single plot - 1pt
o i Single Plot - 1 or more pts
= WDT Single Plat - 1 ar more pts
= ‘ h H | | || 20 Multiplot - 1 or more pts
EE[ | | | ‘ ‘ WDT (Waveform Data Type) includes timing infa.
Or combine points with a bundle node :
pti
@; W aveform Chart
pt M (N plots)
Time Or use timing information in WDT.
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Programmering inder Strukturer

Arbetsmiljé

o Plottar ett antal datapunkter.

Arrays

Grafer

Sammanfattning

CHALMERS

Waveform Graph

o Mojlighet att specificera starttid och steglangd.

Waveform Graph

Plot 0

Amplitude

0 5 10 15 20 25 30 35 40 45 50

LET271: LabVIEW | J. Pedersen

Waveform Graphs:

“wire data directly to waveform graph:

¥ Array | Resulting Graph

1D Single Flot
WDT Single Flot
20 Multiplot

WDT (Waveform Data Type) includes timing info.

Others default to O for g and 1 fordsx.

Cormnbine timing information using a bundle node :
o

Ay @ Waveform Graph

Y array
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Arbetsmiljo Programmering;

Strukturer Arrays Grafer 5

XY Graph

o Plottar x-varden mot y-varden.

XY Graphs:

® array
y array

Multiplot ¥Y Graph:
single plot 1 =g

single plot N==

LET271: LabVIEW

J. Pedersen

ammanfattning

CHALMERS

Single Plot ¥Y Graph:

=== 1Y Graph
(Single Plot)

oog

-+
=
+

E czz 1Y Graph
(N plats)
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inder Strukturer yS 5

XY Graph

Arbetsmiljo Programmeringsg

o Plottar x-varden mot y-varden.

XY Graphs:

® array
y array

Multiplot ¥Y Graph:
single plot 1 =g

single plot N==

Exempel 6: Plottning

Plotta funktionen

ammanfattning

CHALMERS

Single Plot ¥Y Graph:

== 1Y Graph
(Single Plot)

oog

-iig z2z XY Graph
* (N plats)

y = sin(2rzx), = = 0,0.01,...,2
med Waveform Chart, Waveform Graph och XY Graph.

LET271: LabVIEW | J. Pedersen
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Sammanfattning
CHALMERS

Sammanfattning

Arbetsmiljo

e Programmeringsgrunder

Strukturer (for-loop, while-loop, mm.)
e Arrays
Grafer
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Arbetsmiljé Programmeringsgrunder Strukturer s Grafer Sammanfattning

CHALMERS
Sammanfattning

Arbetsmiljo

Programmeringsgrunder

Strukturer (for-loop, while-loop, mm.)
e Arrays

o Grafer
Mer information:

o Gratis LabVIEW-utbildning online fér studenter och larare
(http://sweden.ni.com /webcasts/).

e Learn LabVIEW (http://www.ni.com/academic/students/learn-labview/).

e Introduction to LabVIEW
(http://www.ni.com/getting-started /labview-basics/).

LET271: LabVIEW | J. Pedersen 41/42



Arbetsmiljé Programmeringsgrunder Strukturer s Grafer Sammanfattning

CHALMERS
Sammanfattning

Arbetsmiljo

e Programmeringsgrunder

Strukturer (for-loop, while-loop, mm.)
e Arrays
o Grafer

Mer information:

o Gratis LabVIEW-utbildning online fér studenter och larare
(http://sweden.ni.com /webcasts/).

e Learn LabVIEW (http://www.ni.com/academic/students/learn-labview/).

e Introduction to LabVIEW
(http://www.ni.com/getting-started /labview-basics/).

LabVIEW 3&r installerat pa datorer i JU-024, JU-025 och JU-308-311.
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