Inledande exempel

KORVSKIVNINGS-styrning med Mitsubishi Q02 PLC.

Nedanstdende komma-igang-exempel kan ses som ett embryo till 16sning av ert PLC-
styrproblem inom styrprojektet. Arbeta er igenom detta och sedan skall ni som forberedelse till
nasta labtillfalle géra flédesschema och utkast till kod for PLC-styrningen for ert problem.

Foljande styrning skall astadkommas:

Da strombrytare IN11 ar paverkad ska foljande handa:
Da START paverkas momentant skall cylinder 1 ga fram och tillbaka snabbt en gang. Déarefter ska
cylinder 1 ga fram och stanna i framre laget 3 sekunder och darefter ga tillbaka.

Da strombrytare IN11 ej ar paverkad ska foljande handa:

Da START paverkas momentant skall cylinder 1 ga fram och tillbaka snabbt en gang. Déarefter ska
cylinder 1 ga fram och stanna i framre laget 3 sekunder och darefter ga tillbaka. Detta ska upprepas
under 16 sekunder.

| variabeln COUNT réknas hur manga slag cylindern gjort.

Ldsning:
Borja med att ge de signaler som skall anvandas en bendmning (tag-namn) enligt:

Insignaler:

Start av forlopp START
Bakre l&ge cylinder 1 CYL1BAK
Framre lage cylinder 1 CYL1FRAM
Véxling av forlopp IN11
Utsignaler:

Aktivering cylinder 1 CYL1

Intern Boolsk variabel DRIFT
Heltalsvariabel COUNT

Skapa Nytt projekt i GX IEC Developer

0. Starta GX IEC Developer (under Automation - Melsoft)

1. Valj Projekt > New

2. Vilj PLC series: Q. Valj PLC type: Q Q02(H)

3. | fonstret New Project skrivs sokvag och namn pa katalogen dar filerna i projektet ska hamna:

(katalognamn=projektnamn). OBS!max 8 tecken och inte 446 mm.
Skapa projektet pa din egna area pa. Ex. Z:\styrtekn\projnamn. Klicka Create

4. 1 dialogrutan New Project Startup Option vélj: Empty Project.
Om en dialogruta ”Library update check” dyker upp klicka Close

5. Online>Transfer Setup>Ports, Klicka pa UsB och Vélj RS-232C. Klicka OK.
| Transfer Setup fonstret: Klicka OK



Deklarera Globala variabler
6. | fonstret Project Navigator, dubbelklicka pa Global_Vars
Rod *Asterisk fore nagon rubrik betyder att enheten inte ar kompilerad.

7. Lé&gg in din variabeldeklarationslista med Identifier och MIT-Addr. (Motsvarande IEC-
standardadress fas automatiskt och typen blir automatiskt BOOL). Alla variabler som ar kopplade
till en in- eller utgangsadress maste vara globala.

Observera att GX IEC Developer ér “case insensitive” d v s programmet bryr sig inte om variabler
ar skrivna med versaler eller gemener.
B

8. Ny rad f4s med 3:e verktygsknappen frn hoger. =

9. Da globala variabellistan &r klar ska den se ut enligt nedan. Tillordning dvs hur de olika signalerna
ar kopplade till PLC-systemet framgar av tillordningslista i ”Projektuppgiftshaftet”.

OBS. Sténg fonstret Global Variable List for att andringar ska utforas

Class Identifier MIT-Addr. | IEC-Addr. Type Initial
0[VAR_GLOBAL - |START x4 Salxd BOOL .. |FALSE
1\VAR_GLOBAL + [IN11 KT SalX7 BOOL .. |FALSE
2|\VAR_GLOBAL + [CYL1BAK KA SalX10 BOOL .. |FALSE
3 VAR_GLOBAL « |[CYL1FRAM *B SalX11 BOOL .. |FALSE
4\VAR_GLOBAL - [CYLA1 Y13 Sol2x19 BOOL .. |FALSE
5 VAR_GLOBAL + |[DREIFT M0 SeMX0.0  |BOOL .. |FALSE
6 VAR_GLOBAL ¥ |COUNT Do SelWO.0  |INT ..{0

Startsignalen och den forflutna tiden maste iakttas hela tiden av PLC-systemet dvs styrsystemet
maste hela tiden scanna denna information. Med ett flodesschema kan det beskrivas pa foljande
satt:

YES
DRIFT aktivi 16 s? Satt DRIFT =0
YES "
X 4 Satt DRIFT =1
?
Ar START paverkad? Starta tidtagning

Har CYL1 just kommit

till sitt framre andlage? Oka COUNT med 1

NO




Det ar dags att skapa ett POU (delprogram) som uppfyller funktionen som beskrivs i flddesschemat.
Skapa POU
10. | fonstret Project Navigator markera POU Pool

Klicka pa verktygsknapp POU (4:e fran hoger)
Namnge din POU.

Vilj Class: PRG

Viélj Language of the Body: Function Block Diagram
Klicka OK

(Svara Yes I eventuell dialogruta som dyker upp)

11. I Project Navigator, dubbelklicka pa ditt POU-namn. Dubbelklicka pa Header for att 6ppna
Header-listan som é&r listan for lokala variabler. Den &r for ndrvarande tom men kommer att fyllas
pa senare.

12. | Project Navigator, dubbelklicka pa Body. En Networkruta finns nu i Body fonstret.

Nedanstaende Body byggd av funktionsblock (FBD) skall skapas som motsvarar det tidigare givna
flodesschemat.

VIPPA1
TIMER1 RS
TON START— S Qi —DRIFT
DRFT— IN  Q “R1
T#165— PT ET
2 TRIG1
R_TRIG ADD_E
CYLIFRAM— CLK Q EN ENO —
1— N —COUNT
COUNT—— _IN

For att vélja funktionsblock: Klicka pa ”IC-kapselsymbolen” i verktygsraden. IF

Dialogruta Function Block Selection éppnas. Under Operator Type — All Types for att hdmta TON,
klicka APPLY och placera funktionsblocket i Networkrutan. For beskrivning av de olika
funktionsblocken markera funktionsblocket i Dialogruta Function Block Selection och tryck Help.

Om funktionsblocket inte har ”?” p4 in- och utgangar for inskrivning av in- och utvariabler sa &r
inte Auto Connect aktiverad. Hogerklicka i sa fall i en Networkruta, vélj Auto Connect och hamta
blocket pa nytt.

Vika aWiR
Om man vill addera »?” pa in- och utgangar i efterhand vélj respektive knappar:
Om man vill invertera en in- eller utgang, dubbelklicka alldeles innanfor anslutningen till blocket.
o
13. Skapa ny Network-ruta genom att klicka pa Verktygsknapp =
(samma knapp som for nya rader i Globala variabellistan)

14. Leta fram de block som skall anvandas och l&gg i resp Network-ruta.



15. Sténg Function Block Selection.

Klicka pa en in- eller utgang ?” pa ett funktionsblock for att lagga in variabelnamn pa nagot av

foljande satt:

- Skriv in din variabel (”Identifier””) direkt.

- Hogerklicka pa »?” for att fa en variabellista att valja fran Valj onskad variabel klicka Apply

En benamning kommer att inféras som inte finns i Globala Variabellistan enligt ovan. Denna ar
Instance “Timerl”. TON-funktionen &r en typ av Function Block som innehaller adressering till
nagot intern minnesflagga, register, raknare och/eller timer. Blocket maste darfor vara unikt dvs ha
ett unikt Instance-namn som registreras i Headern. FOr att ange unikt Instance namn:

o

Klicka pa “Instance”. Skriv in ett unikt namn. Tryck Enter

| dialogruta som dyker upp enligt nedan: Vélj: Define local

GX IEC Developer 7.03 e

Yariable doesn't exigt in the header nor in the WL

i Define global... Define lacal... | Cancel

Optionz...

L

I ny dialogruta som dyker upp enligt nedan:

-

Variable Selection (Mode Mew\ar) I. = ﬁ]
Scope Wariables Clazs
<ALLx | |\.ng j
<Global ariables: Identifier
b arufacturer_Lib ;
Standard_Lib Timert
« [m] R Address
Tupe |
|TON -] Type
Type Class |TDN J
' |Fun|:ti|:|n Blocks j Iritial
IEC 511313 ‘ " ] | =
. Comment
=
[ Minimize dialog after Apply Mew OIFF
Cloze Help Define
Valj: Define
Close




16. Aterstdr att forbinda utgang pd TON-krets med ingéng p& RST_M-kretsen. Hogerklicka i
Networkruta. Valj Interconnect Mode Klicka pa utgang och dra en forbindelse till ingang, klicka pa
ingang. Upprepa for 6vriga forbindelser. Da alla forbindelser klara Hogerklicka igen, vélj Select
Mode.

Om man inte kan dra forbindelser sa ar inte Auto Connect aktiverad. Hogerklicka i sa fall i en
Networkruta, valj Auto Connect.

=)
Infoga kommentarer: )

Body i din POU borde nu se ut som figur nedan.

VIPPA1
TIMER1 RS
TON START— S Qi —DRIFT
DRFT— IN  Q “R1
T#165— PT ET
2 TRIG1
R_TRIG ADD_E
CYLIFRAM— CLK Q EN ENO —
1— N —COUNT
COUNT—— _IN




Styrsekvens

Sjélva styrsekvensen for cylindern innebér att den
vantar pA START-signal OCH att cylindern ar i
sitt bakre lage. D& detta intraffar kors cyl 1 ut
(plus) &nda tills den natt framre andlaget. Da
avaktiveras cylinder 1:s styrventil och cylinder gar
tillbaka (minus) tills den natt bakre laget osv. Med
ett flodesschema kan styrférloppet beskrivas som
figur till hoger:

/START paverkad

ol OCH \£

Wdeﬂ i bakre lage?

Aktivera cylinder 1

<

/f/' TN
_~"Ar cylinder! ™ NO
\\Lffmre Iagi'?//

\Avaktivera cylinder 1

[A

<
|

o
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_""Ar cylindert ™~__ NO
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v

Aktivera cylinder 1

<
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T i framre lage?
\\ //
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YES




Ovanstaende flodesdiagram blir beskrivet som Sequential Function Chart (SFC) enligt nedan:

Initial

=[START AND CYL1BAK]

HOPP

STEGH
"CYLT”

=[CYL1FRAM]

STEG2
"MO OPERATION"

=[CYL1BAK]

STEG3
"CYL1_PLUS”

=[CYLIFRAM]

STEG4
"DELAY_35"

=[DELAY_KLAR]

STEGS
"CYL1_MIMNUS"
"MOLLSTALL_DELAY_TIMER"

=[CYL1BAK]

STEGE
"MO OPERATION"

KLART =[NOT IN11]
HOPP

Skapa nu ett POU och vélj programmeringsséatt Sequential Function Chart (SFC) som &r gjort for att
anvandas for sekventiella forlopp. Detaljer pa nasta sida.



Skapa ett SFC-POU
17. 1 fonstret Project Navigator markera POU Pool
Klicka pa verktygsknapp POU (4:e fran hoger)
Namnge din POU (Sekvens).
Viélj Language of the Body: Sequential Function Chart
Klicka OK (Svara Yes | eventuell dialogruta som dyker upp)

18. 1 Project Navigator, dubbelklicka pa ditt POU-namn. Dubbelklicka p& Header for att fa fram din
lokala variabellista Komplettera din lokala variabellista med eventuella lokala variabler (Behdvs ej
i detta exempel.)

Andra standardinstéllningar i GX IEC Developer s att bl a kommentarer i SFC syns:
View>Extended Information>SFC editor

19. 1 Project Navigator, dubbelklicka pa Body En grundstomme till ett SFC-program finns nu i Body

fonstret. Bygg upp strukturen pa ditt program enligt foregaende sida och med hjalp av
nedanstaende:
=

Infoga nya steg och 6vergangar med verktygsknapp:

Infoga parallella/alternativa processer med verktygsknappar:

|_<]
Infoga hopp med verktygsknappar

Infoga endast steg med: =

Infoga endast Gvergang med: v

20. Det sista steget (Final Step) visas som ett tvérstreck och ger aterhopp till Initial Step. Om du rakar
radera Final Step: Ga till Edit > Modify > Final Step

21. Klicka pa dina steg och namnge varje steg med ett unikt namn. T ex Steg1, Steg2, Steg3 osv
22. Klicka pa évergangar och ange 6vergangsvillkor pa nagot av satten nedan:

- Om 6vergangsvillkor ar enkelt: En variabel: eller en enkel funktion av variabler:
Tools > Edit Transition Condition och skriv in funktionen: T ex: START AND CYL1BAK
Vid dvergangen syns nu:  =[ 6vergangsvillkor ]
Fyll pa detta sitt i alla 6vergangsvillkor forutom det sista ’KLART”

- Om o6vergangsvillkor ar komplicerat: Skriv in namnet pa 6vergangen
Dubbelklicka pa dvergang. Valj Language: T ex Function Block Diagram.
Programmera som FBD enligt tidigare och benamn den enda resulterande utgangen med TRAN.
TRAN ettstalld innebar att Gvergangen sker.

Skapa pa detta sitt det sista 6vergangsvillkoret ’KLART” enligt figur nedan.

4 pou? [PRG] Body [SFC] Transition KLART [FED] =N ECR ==
OR
INT1— ——TRAN
DRIFT —




23. For att lagga in vad som skall handa i varje steg dubbelklicka pa steget och ange de handelser
(aktiviteter) som ska vara associerade till steget. Olika handelser pa olika rader i Action
Association fonstret.

Héndelserna kan vara av 2 slag:

- En variabel. (Variabeln ar 1 (TRUE) endast under den tid steget ar aktivt)
| vart exempel i Stegl anges variabeln CYL1

- En héndelse i form av ett program s k Action.

- Skriv in namnet pa din Action i Action Association-fonstret
- Sténg Action Association-fénstret

- Markera Action Pool

- Klicka pa verktygsknapp
- Skriv in ditt Action namn. Valj programsprak. Klicka OK
- Klicka pa Aktion namn i Project Navigator.

For att infoga kommentarer for varje steg. Klicka pa steget och valj kommentarknapp

Skriv dina kommentarer inom citationstecken for att skilja dem fran stegets namn.
Det kan vara lampligt att ange alla actions i steget i kommentarer.

- Programmera dina h&ndelser (aktiviteter), ange handelser for varje steg och kommentara enligt
figurer nedan och pa nésta sida:

s POU2 [PRG] Action CYLL_MINUS [FED] =R <=
MOVE ﬂ
FALSE— _IN ——CYL1
-
et SEKVENS [PRG] Action CYLL_PLUS [FED] o[- 3]
MOVE
TRUE— _IM —CYL1
et SEKVENS [PRG] Action DELAY_3S [FBD] o= |3 |
DELAY_TIMER -
TOM

TRUE— IM @ ——DELAY _KLAR
T#35— PT  ET

- |
wet SEKVENS [PRG] Action NOLLSTALL_DELAY_TIMER [FBD] o[- ]
DELAY _TIMER =
TON
FALSE — IM Q—
~PT ET -




Initial

=[START AMD CYL1BAK]

HOPP
STEGH 7 | Action Association Stegl | — @
CYLA P CYL1 |
=[CYL1FRAM]
STEG? i : » —
X
"NO OPERATION" 7| Action Association Steg2 | = @
4
=[CYL1BAK]
"CYL1_F‘LU§TEGS 7| Action Association Steg? | — @
p-CYL1_PLUS |
=[CYL1FRAM]

STEG4 — o —
"DELAY_3S" ¥ | Action Association Stegd | = @

P-DELAY_35
=[DELAY KLAR]

STEGS [ = T . R— |
"CYL1_MINUS" Action Association STEGS | — @
"NOLLSTALL DELAY TIMER" PEYL‘I_MINUS

MOLLSTALL DELAY TIMER
=[CYL1BAK] = =

STEGE ) .
"NO OPERATION" 7 | Action Association Stegh | = @

>
KLART =[MOT IN11]
HAOPP
Skapa Task

24. 1 Project Navigator markera Task Klicka pa verktygsknapp TSK
Namnge din Task.

25. | Project Navigator dubbelklicka pa ditt Task-namn
| ditt TASK-fonster ska du valja vilka POU som ska inga.(l detta fall finns tva POU:er. Lagg till
rad pa redan kant satt.) Skriv in ditt POU-namn (eller vélj fran listam h a knapp:

POU name Co

10



Ditt projektfonster bor nu se ut enligt féljande:

=

@( EPrﬂject [z \Inledande_exem pel_stjrrteknik".kﬂrv]é
-l

['] Parameter

...l Module Configuration
=4 Task_Pool
.. {D" TASKL (Prio = 31, Event = TRUE)
...... 55 DUT_Pool
...... g Global Vars

(- POU_Pool
EI u[g* KORV [PRG]
----- o Header

L 60} Body [FED]
EI ard SEKVENS [PRG]
..... o Header
E-si Body [SFC]
.60, KLART [FBD]
- a2 Action_Pool
.68} CYL1_MINUS [FED]
.88 CYLL_PLUS [FED]
.60, DELAY 35 [FBD]
.60 NOLLSTALL_DELAY_TIMER [FBD]

1
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Overgéngsvillkor gjorda i FBD

Actions (Handelser) gjorda i FBD




Kompilering av projekt
26. Kompilera projektet

Viélj Project > Build
Rod *Asterisk fore nagon rubrik betyder att enheten inte ar kompilerad.
Beror oftast pa att den aktuella POU:n ej ar kopplad till nagon Task.

27. Om meddelandet: The program is too big for actual configuration dyker upp, gor foljande:
| Project Navigation: Dubbelklicka pa PLC
Andra: Program capacity > Microcomputer (0-14) till: 2 Kbytes8

28. FOrhoppningsvis inga fel/varningar??? Korrigera annars. Genom att markera felet i
kompileringslistan och trycka ”Show” leds man till rédmarkerade felstéllet.

Overforing av program till PLC

29. Om du inte har kopplat ihop PLC:n med processen du ska styra sa gor det nu innan du ansluter
PLC:n till matningsspanning.

30. For dverforing av det kompilerade programmet till PLC :

Project > Transfer > Download to PLC. o

Vid éverforing maste programexekveringen i PLC:t stoppas vilket gérs genom att svara pa fraga i

borjan pa programdéverforingen. Lyckas inte 6verforingen ga till:

Online > Transfer Setup >Ports.

Klicka Serial USB och valj RS-232C. Programmet ligger kvar i PLC:s programminne tills ett nytt
program 6verfors. Reset av PLC innebér nollstéllning av flaggor och register men inte radering av
program. (Om PLC:n begér Keyword, Skriv: ffffff.) Starta exekvering genom att svara pa fraga da
Overforing klar. Run/Stop/reset-hantering finns under Online-meny.

ON-line-andring.

31. Mindre andringar av av programmet kan goras on-line med PLC i RUN-lage. Gor dndringarna i
GX IEC, kompilera inte utan valj Project > Online Program Change

Monitorering vid kérning

32. Gatill On Line och aktivera Start Monitoring. c
Signaler och tillstand kan nu féljas i de olika POU:erna.

Spara Projektet pa egen area.

33 Vid nagra tillfallen har vi observerat instabilitet och forlorade projekt da man jobbat 6ver natet mot
Z:. Om du har problem med detta jobba mot egna lokala enheten C: pa labbdatorernas harddisk.
Kom dock ihag att spara pa er egen Z: -area innan ni loggar ut. Det kan goras genom att ga till
Extras — Project Backup och spara det i en backup-fil av typ *.pcd. Projectet kan sedan dppnas igen
via Extras — Project Restore. Ett annat sétt ar att anvanda Save As pa vanligt satt men da blir
projektet ganska utrymmeskravande. (En tredje variant ar att markera Project i Navigatorn och
vélja Export. Da komprimeras projektet till en .asc — fil som kan importeras pa motsvarande satt
nésta arbetstillfalle.)

Obs! Ta for vana att da och da under ett labpass att gora en backup-sparande ifall nagot skulle
h&nda nar ni jobbar med programmet.
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